Ffmpeg

De Guía Ubuntu

Ffmpeg es un programa sin interfaz gráfica que permite convertir o transformar entre formatos multimedia, tanto de video como de audio. Aunque existen otros programas, algunos sin necesidad de usar comandos, es una de las opciones con más posibilidades y es muy rápida.

El paquete viene con tres programas:

  • ffmpeg: ffmpeg es una herramienta en línea de comandos para convertir ficheros de vídeo, flujos de red o la entrada de una tarjeta de TV a varios formatos de vídeo.
  • ffserver: es un servidor de flujo para todo lo que ffmpeg pueda usar como entrada (ficheros, flujos, entrada de la tarjeta de TV, cámara web, etc).
  • ffplay: es un reproductor de medios muy simple y portable que utiliza las librerías ffmpeg y la librería SDL.

Tabla de contenidos

Instalación sencilla

Lo más fácil y rápido es hacer uso del repositorio de paquetes de Medibuntu donde viene una versión de ffmpeg que compilada con las opciones más comunes, incluyendo soporte para el codec x264 entre otros.

La instalación de este repositorio se hace con este churro:

$ sudo wget --output-document=/etc/apt/sources.list.d/medibuntu.list http://www.medibuntu.org/sources.list.d/$(lsb_release -cs).list && sudo apt-get --quiet update && sudo apt-get --yes --quiet --allow-unauthenticated install medibuntu-keyring && sudo apt-get --quiet update

Adicionalmente se recomiendo instalar estos dos paquetes. El primero hace que las aplicaciones del repositorio de Medibuntu aparezcan en el Ubuntu Software Center (Ubuntu 9.10+) (o Añadir/Quitar Aplicaciones (en versiones de Ubuntu anteriores a 9.10). La segunda permite a los usuarios generar un reporte de error contra los paquetes de Medibuntu y enviarlo al bugtracker de Medibuntu.

$ sudo apt-get --yes install app-install-data-medibuntu apport-hooks-medibuntu

Acto seguido ya podremos instalar ffmpeg con todas sus dependencias:

$ sudo apt-get install ffmpeg libavcodec-extra-52

Instalación complicada

Existe una versión inicial en universe (véase activar universe y multiverse). Sin embargo esta versión esta algo limitada para algunos tipos de formatos multimedia.

Para obtener esta versión puedes conseguirlo de dos maneras distintas: instalando desde los fuentes del paquete o desde el paquete binario generado. Si tienes prisa elige la segunda opción. El paquete te lo puedes descargar de www.dante.net.ve.

Otra opción mas manual va a necesitar de que ya tengas activados los repositorios universe y multiverse de Ubuntu.

Imagen:Nota clasica.png Las acciones que tienes que hacer a continuación tendrás que hacerla como usuario root.

Como vamos a compilar, serán necesarios una serie de paquetes de desarrollo

dpkg-dev libimlib2-dev texi2html liblame-dev libfaad2-dev libmp4v2-dev libfaac-dev libxvidcore4-dev libtheora-dev
libgsm1-dev libogg-dev libvorbis-dev liba52-dev libdts-dev libsdl1.2-dev libraw1394-dev libdc1394-13-dev quilt

Las podemos instalar mediante Synaptic o la terminal con los siguientes comandos:

$ sudo aptitude install dpkg-dev libimlib2-dev texi2html liblame-dev libfaad2-dev libmp4v2-dev
$ sudo aptitude install libfaac-dev libxvidcore4-dev libtheora-dev libgsm1-dev libogg-dev libvorbis-dev  
$ sudo aptitude install liba52-dev libdts-dev libsdl1.2-dev libraw1394-dev libdc1394-13-dev quilt

Vamos ahora al directorio donde se bajarán los fuentes del paquete ffmpeg:

$ cd /usr/local/src

Nos bajamos los fuentes del paquetes:

$ sudo apt-get source ffmpeg

Hay que bajarse el parche para que funcione el soporte para AMR, descarga ffmpeg_enable_amr.patch.bz2.

Cambiamos al directorio con los fuentes de ffmpeg y aplicamos el parche:

$ cd ffmpeg-0.cvs20050918
$ bzcat ../ffmpeg_enable_amr.patch.bz2 | patch -p1

Ahora construimos el paquete con la opción risky:

$ DEB_BUILD_OPTIONS="risky" dpkg-buildpackage

Volvemos al directorio /usr/local/src e instalamos el paquete generado:

$ cd ..
$ dpkg -i ffmpeg_0.cvs20050918-5ubuntu1_i386.deb

Ahora ya tenemos ffmpeg con soporte para MP3 y AMR. Bien ya está casi completada la tarea. Tenemos que evitar que apt actualice nuestra versión compilada por una actualización que no tenga soporte para MP3 y AMR. A esto se le llama pinning. Hay que editar las preferencias de apt:

$ gedit /etc/apt/preferences

Y añadir estas líneas:

Package: ffmpeg
Pin: version 0.cvs20050918-5ubuntu1
Pin-Priority: 1001

Ver también

Enlaces extrenos

Herramientas personales